Go Back   Cyber Tech Help Support Forums > Operating Systems > Linux

Notices

Linux Problem solving for all open source distributions of Linux, such as Debian/Ubuntu, Fedora, RedHat, Suse, Mandriva and other proprietary unixes such as Solaris, SGI Irix. Newbie friendly too!

Reply
 
Topic Tools
  #1  
Old April 5th, 2023, 01:51 AM
Jaytee's Avatar
Jaytee Jaytee is offline
Senior Member
 
Join Date: May 2002
O/S: Linux
Location: Hamilton New Zealand
Posts: 3,573
dpms problem..

To prevent getting a black screen and no sound after ten minutes or so at idle, I do in a terminal this:
xset -dmps

Which has the result of turning off the display power management system for the rest of the session. On reboot dpms starts again.
Does any one know of a script I can use to turn off this feature permanently???
Reply With Quote
  #2  
Old April 9th, 2023, 01:49 AM
Jaytee's Avatar
Jaytee Jaytee is offline
Senior Member
 
Join Date: May 2002
O/S: Linux
Location: Hamilton New Zealand
Posts: 3,573
Bump any help anyone????
Reply With Quote
  #3  
Old April 11th, 2023, 09:54 PM
Ensign Tzap Ensign Tzap is offline
Senior Member
 
Join Date: Jul 2005
O/S: Windows 7 64-bit
Posts: 947
Hmmmm.........


Go into the BIO's settings.
Look for power settings.
Look for Sleep Mode, or Screen Saver.
Disable them, or set the Power Saver Mode to: Always On.




Signed: Ensign Tzap
Reply With Quote
  #4  
Old April 12th, 2023, 12:46 AM
Jaytee's Avatar
Jaytee Jaytee is offline
Senior Member
 
Join Date: May 2002
O/S: Linux
Location: Hamilton New Zealand
Posts: 3,573
Thanks for your response ET.
My bios has nothing remotely like the suggestions you gave.
I am convinced that it is a system bug and could be fixed by going back a couple of updates. Usually bugs in Linux are fixed fairly quickly but this one is taking a while.
I think I will study the release notes for the next version of Mint (Vera) to see if the problem still exists..
Reply With Quote
  #5  
Old April 12th, 2023, 09:09 PM
Ensign Tzap Ensign Tzap is offline
Senior Member
 
Join Date: Jul 2005
O/S: Windows 7 64-bit
Posts: 947
Quote:
Originally Posted by Jaytee View Post
Thanks for your response ET.
My bios has nothing remotely like the suggestions you gave.
Huh???


Unless this computer your using is an ancient relic.
It should have "Power Management".
And "Wake System from":
USB
Lan
Keyboard
Mouse
EXAMPLE:
Reply With Quote
  #6  
Old April 12th, 2023, 10:56 PM
Jaytee's Avatar
Jaytee Jaytee is offline
Senior Member
 
Join Date: May 2002
O/S: Linux
Location: Hamilton New Zealand
Posts: 3,573
Quote:
Originally Posted by Ensign Tzap View Post
Huh???
Sorry ET,
I was looking for love in all the wrong places. I have a gigabyte board with award 2014 bios
I thought i was looking for a specific function to disable which I did not find.
Do I need to disable the PME function????
Reply With Quote
  #7  
Old April 12th, 2023, 11:48 PM
Ensign Tzap Ensign Tzap is offline
Senior Member
 
Join Date: Jul 2005
O/S: Windows 7 64-bit
Posts: 947
Yes,
You should try disabling the "PME Event Wake Up".
Then see if that solves the Sleeping Issue, every ten minutes when no activity is detected.

There is also, "ACPI Suspend Type".
This setting dictates what power saving state your system goes into.
ACPI replaces the older Advanced Power Management (APM) scheme and requires a compatible OS,
such as Windows 98 and up, along with several Linux distributions.


Signed: Ensign Tzap
Reply With Quote
  #8  
Old April 13th, 2023, 02:10 AM
Jaytee's Avatar
Jaytee Jaytee is offline
Senior Member
 
Join Date: May 2002
O/S: Linux
Location: Hamilton New Zealand
Posts: 3,573
Many thanks,
Will give them a try and let you know the outcome...
Reply With Quote
  #9  
Old April 14th, 2023, 12:39 AM
Jaytee's Avatar
Jaytee Jaytee is offline
Senior Member
 
Join Date: May 2002
O/S: Linux
Location: Hamilton New Zealand
Posts: 3,573
Changing the bios setting has had no effect on DPMS..
Reply With Quote
  #10  
Old April 14th, 2023, 07:23 PM
Ensign Tzap Ensign Tzap is offline
Senior Member
 
Join Date: Jul 2005
O/S: Windows 7 64-bit
Posts: 947
Deleted

Last edited by Ensign Tzap; April 14th, 2023 at 11:15 PM. Reason: editing
Reply With Quote
  #11  
Old April 14th, 2023, 11:14 PM
Ensign Tzap Ensign Tzap is offline
Senior Member
 
Join Date: Jul 2005
O/S: Windows 7 64-bit
Posts: 947
Hmmm.......


Quote:From TomsHardware
Video Off Method: The DPMS (Display Power Management System) option allows the BIOS to control the video display card if it supports the DPMS feature. The Blank Screen option simply blanks the screen — use this for monitors without either power-management or “green” features. The V/H SYNC Blank option blanks the screen and turns off vertical and horizontal scanning.

The next thing you could try is the ACPI Suspend Type settings.
You could try S1 or S3 settings.
Changing this setting may not have any effect either, but it is worth giving it a try.

Edit:

Check if INVIDIA or AMD have Video Control Tools App for Linux.
Note: You'll need to check what GPU Chipset you have, and if either of the Linux Video Control Tools will work with it.



Signed: Ensign Tzap
Reply With Quote
  #12  
Old April 16th, 2023, 11:53 PM
Jaytee's Avatar
Jaytee Jaytee is offline
Senior Member
 
Join Date: May 2002
O/S: Linux
Location: Hamilton New Zealand
Posts: 3,573
no results sadly..
Reply With Quote
  #13  
Old April 23rd, 2023, 11:52 PM
Ensign Tzap Ensign Tzap is offline
Senior Member
 
Join Date: Jul 2005
O/S: Windows 7 64-bit
Posts: 947
Hmmm...........


Maybe try getting the latest Video Drivers?


Here is the NVidia Linux Driver Site:
https://www.nvidia.com/en-us/drivers...splay-archive/


Here is Linux® Drivers for AMD Radeon™ and Radeon PRO™ Graphics:

https://www.amd.com/en/support/linux-drivers




Signed: Ensign Tzap
Reply With Quote
  #14  
Old April 24th, 2023, 12:05 AM
Jaytee's Avatar
Jaytee Jaytee is offline
Senior Member
 
Join Date: May 2002
O/S: Linux
Location: Hamilton New Zealand
Posts: 3,573
Yes I have. AMD graphics accelerator.
Thinking of swapping to Ubuntu as the problem does not seem to exist in that system for some weird reason.
Reply With Quote
  #15  
Old June 17th, 2023, 12:43 AM
Jaytee's Avatar
Jaytee Jaytee is offline
Senior Member
 
Join Date: May 2002
O/S: Linux
Location: Hamilton New Zealand
Posts: 3,573
Update...
I changed my distribution to Ubuntu. Problem evaporated..
Reply With Quote
Reply

Bookmarks

Topic Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 12:25 PM.