Go Back   Cyber Tech Help Support Forums > Hardware > Hardware

Notices

Reply
 
Topic Tools
  #1  
Old December 8th, 2010, 12:48 AM
TheLeapist TheLeapist is offline
New Member
 
Join Date: Dec 2010
Posts: 8
Question How do I allocate more power to my soundcard (PCI slot or onboard)?

I recently installed a second ati HD 5770 for crossfire and ever since my soundcard has been emitting no sound whatsoever and the onboard sound is extremely scratchy. I am convinced that it's because they're not receiving enough power anymore. So I was wondering how to up that.

My Power Supply Unit is 700w so it should be more than enough to handle crossfire.

Any ideas? Maybe I am way off track with the power thing? Any help would be greatly appreciated.
Reply With Quote


  #2  
Old December 8th, 2010, 03:36 PM
Murf's Avatar
Murf Murf is offline
Moderator
 
Join Date: Oct 2001
O/S: Windows 11
Location: Newport News VA
Age: 77
Posts: 17,351
Welcome to CTH

Although your sound and putting in the video card may be related, I doubt it. What version of Direct X are you running? If the cards were not getting enough power then the puter probably would not boot.

The 700W power supply should be ample, however, it depends on the voltage not the wattage it is giving out.. Those cards will pull (full load about 300W in 3d mode),

Your sound card, maybe dislodged when putting the 2nd Video card in? Do these cards need their own power cord ie 6 pin PCIe power?
Reply With Quote
  #3  
Old December 8th, 2010, 06:50 PM
TheLeapist TheLeapist is offline
New Member
 
Join Date: Dec 2010
Posts: 8
Thanks for the welcome and quick response.

So I tried updating/installing directx (I just recently reformatted my computer so it may not have even been there yet) and that actually seemed to improve on the scratchiness a bit, but it's definitely still there. I know it can't just be a problem with the sound card because of how the onboard sound is scratchy, but I have taken out and reinserted my sound card firmly a couple times to no avail.

The two video cards each require one 6 pin and the sound card doesn't need one at all I believe.

Thanks so much for your help.
Reply With Quote
  #4  
Old December 8th, 2010, 07:50 PM
Murf's Avatar
Murf Murf is offline
Moderator
 
Join Date: Oct 2001
O/S: Windows 11
Location: Newport News VA
Age: 77
Posts: 17,351
So video is great just the sound sucks! ANd the sound was OK with just one video card. BTW: Nice vid cards.

Get into BIOS setup and see if you have a menu item:

"PCI Latency" and if so and it is adjustable try reducing it. Save and Exit.

ATI Video cards, I believe have their own audio chip.
Integrated HD audio controller
  • Output protected high bit rate 7.1 channel surround sound over HDMI with no additional cables required
  • Supports AC-3, AAC, Dolby TrueHD and DTS Master Audio formats
What version driver are you using?

Latest VISTA/Win 7 drivers HERE
Reply With Quote
  #5  
Old December 8th, 2010, 11:16 PM
TheLeapist TheLeapist is offline
New Member
 
Join Date: Dec 2010
Posts: 8
I can't find "PCI latency" anywhere. I even downloaded my mobo's manual and searched there. My BIOS is pretty intense though with extreme overclocking options and the like. So is there anything else it would be called?

Also, I do have the latest ATI drivers. I always keep up to date with those and always completely sweep the old driver before installing the new.

Thanks again for being so awesome and helpful.
Reply With Quote
  #6  
Old December 9th, 2010, 08:11 AM
Lawrencely's Avatar
Lawrencely Lawrencely is offline
New Member
 
Join Date: Apr 2010
O/S: Windows 7 32-bit
Posts: 26
sorry,I dont know that.but I believe your problem would be best to do. good luck.
Reply With Quote
  #7  
Old December 11th, 2010, 01:01 AM
jaydeee's Avatar
jaydeee jaydeee is offline
New Member
 
Join Date: Apr 2010
Posts: 25
Just wondering if your sound is good without the additional video card?
Reply With Quote
  #8  
Old December 11th, 2010, 09:44 AM
TheLeapist TheLeapist is offline
New Member
 
Join Date: Dec 2010
Posts: 8
Yes it is
Reply With Quote
  #9  
Old December 11th, 2010, 08:47 PM
Murf's Avatar
Murf Murf is offline
Moderator
 
Join Date: Oct 2001
O/S: Windows 11
Location: Newport News VA
Age: 77
Posts: 17,351
Sound Card; brand??

Go to the DEVICE MANAGER.
Double-click the Sound, Video and game controller and ensure all the ATI WDM components listed below are present and functioning properly.
ATI Specialized PCD WDM VBI Codec
ATI WDM Rage Theater Audio
ATI WDM Rage Theater Video
ATI WDM TV Audio Crossbar
ATI WDM TV Tuner
Specialized MVD WDM VBI Codec
Right click and select properties for each ATI WDM component and ensure that the properties state that This device is working properly.
Reply With Quote
  #10  
Old December 11th, 2010, 09:01 PM
TheLeapist TheLeapist is offline
New Member
 
Join Date: Dec 2010
Posts: 8
My sound card is a Turtle Beach Riviera and all devices are working properly.
Reply With Quote
  #11  
Old December 11th, 2010, 10:08 PM
smurfy's Avatar
smurfy smurfy is offline
Cyber Tech Help Moderator
 
Join Date: Sep 2000
O/S: Linux
Location: Christchurch New Zealand
Posts: 9,539
Have you checked that the 5770 HDMI sound output hasn't been made the default device?

Control panel - sound.
Attached Images
File Type: jpg DefaultSoundDevice.jpg (89.2 KB, 2 views)
Reply With Quote
  #12  
Old December 11th, 2010, 10:31 PM
TheLeapist TheLeapist is offline
New Member
 
Join Date: Dec 2010
Posts: 8
Yes I have actually.
Reply With Quote
Reply

Bookmarks

Topic Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT +1. The time now is 07:13 PM.