Go Back   Cyber Tech Help Support Forums > Hardware > Hardware

Notices

Reply
 
Topic Tools
  #1  
Old March 1st, 2021, 09:07 AM
chris18 chris18 is offline
Senior Member
 
Join Date: Sep 2000
O/S: Windows 7 64-bit
Location: Euro Free England
Age: 80
Posts: 626
Toshiba Equium P300-16T Charging Question

The above laptop, purchased in 2008, has been sitting unused for a couple of years but I am now getting it working again to give to a young family member for school work post covid-19.

The battery had failed previously as far as I was aware so it could only be used on AC charge. I have bought two compatible replacement batteries. When I installed the first the charging light kept flashing continuously and even after 18 hours of charging the battery level was zero.

I then bought the 2nd battery (in case the first may have been faulty) and this has just been installed but this time the battery light is continous red.

I had to restore Windows to wipe the laptop but used the Windows restore not the Toshiba recovery. I have also now upgraded the laptop from W7 Home to W10 home.

I am unsure as to whether the battery light should be continuous during charge or flashing as I have no manual to refer to.

Also, am I correct in believing I have lost any Toshiba related software as a result of the restore/upgrade. If not, how do I locate it?

PLEASE IGNORE

Think I have resolved issue. New battery showing 100% charge and charging light out
.

Last edited by chris18; March 1st, 2021 at 10:45 AM.
Reply With Quote


Reply

Bookmarks

Topic Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT +1. The time now is 08:10 AM.