Cyber Tech Help Support Forums

Cyber Tech Help Support Forums (
-   Linux (
-   -   Linux Mint and Zoom (failed) (

Total Noob June 7th, 2021 04:50 PM

Linux Mint and Zoom (failed)
My desktop and laptop don't support Zoom backgrounds; the chips are inadequate according to Zoom.

I was hoping to try Zoom with Linux Mint thinking that the open source version might allow what the Windows version does not. My computer is dual bootable.

Unfortunately, I never got the chance. Zoom isn't in the repository despite its usefulness the world at the moment, so I went to Zoom's site, and I followed Zoom's instructions exactly -- there being no mention of restrictions on the kind of chips you are using -- cutting and pasting the various codes into the terminal. I clicked install, watched it install, get basically to the end of the install, and then spectacularly fail to complete installation. Several times.

So now Linux Mint is useless. I'd like to get rid of it and replace it with another flavor with two caveats: I want it in the same place and install it without taking any risk of data loss on the Windows side or fooling around with partitions.

I knew at one time that was possible, though a difficult job. Has that changed, and where do I get instructions for that task?

And is there a distro that has Zoom built in and is capable of utilizing the background feature on an older PC or laptop?

I'll note in passing that I didn't see Slack or Teams as part of distros either.

lufbra June 8th, 2021 03:49 PM

Have you read and followed the instructions given in Zoom's own webpage?

Installing or updating Zoom on Linux

Total Noob June 9th, 2021 08:19 PM


Originally Posted by lufbra (Post 1309874)
Have you read and followed the instructions given in Zoom's own webpage?

As I said before, to the letter.

lufbra June 12th, 2021 04:05 PM


Originally Posted by Total Noob (Post 1309881)
As I said before, to the letter.

Sorry about that, have you tried contacting them on that same page where it says Contact Support? Another suggestion would be to look into seeing of the Wine software supports Zoom.

Total Noob December 27th, 2021 04:29 PM

I persisted in the effort to get Zoom on my Linux Mint dual-OS Compaq with an AMD 64 chip and to get it to work with my wifi dongle over Xmas.

It was not only frustrating and ultimately useless, but it highlighted my point that Linux is not ready for general home users and certainly not for commerce in situations where employees use computers as tools of other jobs, like selling insurance or doing accounting, as opposed to working in the computer industry per se.

Here goes.

I normally upgrade my Linux Mint install about once a year; to do that I have to bring my mesh relay to the computer and hard wire them together, there being no wifi access. It's a little hassle, not much. As of Xmas morning, I was using version 17.3.

I used the normal upgrade manager app in the Administration menu and launch and discover I am "up to date" which seems bizarre because I have not updated in a while and there have been all kinds of recent threats that needed patching for which there were no patches. I look around to see what is up with that and discover that 17.3 is not only obsolete but that support was discontinued in 2019.

I hunt down instructions to get the upgrade manager to offer an upgrade to the current version, 19.3, and get them. These require cut and paste programming to run in terminal mode to get the right button to show up in the upgrade manager that handles the entire task.

Alas, no luck. The instructions failed because whatever repository held the adjustments was MIA.

So next I look for instructions to do the upgrade within terminal mode. I'm against a fresh install because I had a bad experience once in which I could not prevent some distro from taking over the entire hard drive either by default or without giving me enough time to opt out when I wasn't tending it, I don't know which, and I'm not inclined to make that mistake twice as I have hundreds or thousands of curated mp3's and videos on the Windows side and I'm not prepared to lose that.

Finally, I find my way to the Mint community site and get what seems like the right instructions, carefully cut and paste them in the correct order, and launch the whole thing, only to discover that whomever is sending the files has hardly any bandwidth. 2GB of files come at a rough average of 150kb per second, which is more or less what I got when I was using a 2400 baud modem.

Worse yet, the download has to be tended to because permissions have to be granted at random times. Finally, about 4 hours later, I have the whole download, and I give the instruction to install, and that too needs to be tended with various permissions needed at random times, at which point everything gets unpacked slowly and installed slowly and two hours later with me shuttling in and out to give permission, it finishes.

I reboot and discover I now have Version 18.0, not 19.3 as promised.

How do you get from 18.0 to 19.3? Slowly. Very slowly. Especially if it is Xmas and you have other things going on and cannot babysit a computer.

First you upgrade to 18.3, then to 19.0, and then to 19.3.

And each step is about the same. A very, very slow download that needs tending and a very, very slow install that needs tending, about 6 hours in all, with the further complication that 18.3 refused to accept my password to log in, so I had to boot to it in recovery mode out of grub, which in turn indicated a whole other set of issues because as a guest I was still able to administrate despite not having needed to have a password to get to terminal, and presumably allowing other changes with a mere yes or no or if a password was needed to authorize changes, one that might have inadvertently been left in the open if the computer had a different OG user.

Anyway, now it is time to move up to 19.0, and I follow instructions requiring me to create a snapshot so I can restore the current installation if the upgrade fails. This is useless to me; I don't have any data on the Linux side, so I don't need it, but there is no workaround. That takes about an hour and then I am allowed to start downloading the upgrade, which takes four hours and needs to be tended to, whereupon I launch the installation instructions only to be told the next morning that the installation has failed as I am out of room on my 20gb hard drive partition which has nothing on it except Linux Mint. I am told to clear some space to finish the install.

This is very, very bizarre because before you start the download of 19.0, you must go through a simulation intended to tell you if it will install, and I have passed that with flying colors.

Ok. I try the still balky 18.3 which lets me enter in guest mode, install BleachBit, and it slowly clears out about 2gb of useless junk that probably should have been cleared before the installation program started installing new junk, and that takes a half hour, and then I am allowed to resume installing 19.0, and that took a couple of hours too, and now I am ready to reboot and move up to 19.3.

Fortunately, the login problem evaporated by the time I got to 19.0, but there was still no one button upgrade launching there either. More terminal, more slow downloads with permissions necessary, and another close call with being out of room.

All told, 30 hours of shuttling in and out to make sure it had permission, that it wasn't overloaded, and that each sequential upgrade completed and let me in.

Finally, finally, time to find out if my wifi dongle would work.

Go back to the community. Follow the instructions scrupulously with cut and paste. And nothing. There last instruction required a command needed to set up the driver was not found in Mint even though the instruction came from the Mint community and at least one other forum user found success. So I'm still dead in the water on that.

Nevertheless, I discover that Zoom is in the repository. I should have noticed zero reviews, but I did not.

It took forever with the slow bandwidth to download, and it took three tries before Zoom fully installed, and about a dozen attempts to launch it after that before it in fact launched and didn't do nothing.

Sure enough, it eventually launched and I put my USB camera into the slot, turned on the video setting and there I was! Zoom!

But it was too good to be true. I was out of focus so I adjusted the lens and not more than 10 seconds later the monitor schizzed out and I was at the Linux equivalent of Blue Screen of Death.

I rebooted several more times, launched Zoom a few more times, and discovered BSOD immediately on launch if the camera was previously plugged in, and BSOD when I plugged it in if had not been in on launch. In other words, useless.

Candidly, I don't really want to have to upgrade all the computers in my office each time Microsoft moves Windows up another number to add features I can live without but also not remain in the stone age. And I have political and personal and consumer objections to Apple whose products are really just for people with too much money to burn and whose aim is to be the cool kid on the block.

But there really isn't another choice. I can do this job because I have been fooling around with Linux for a while, but others for whom time is money are going to need Tech Support or an IT department to do dicey upgrading while babysitting the computers overnight or on weekends just to avoid Windows or Apple upgrades, and it doesn't seem cheaper or surer in the end.

Jaytee January 18th, 2023 06:31 AM


All times are GMT +1. The time now is 08:04 PM.

Copyright © Cyber Tech Help. All rights reserved. All other trademarks are the property of their respective owners.