Go Back   Cyber Tech Help Support Forums > Software > Internet / Browsers

Notices

Reply
 
Topic Tools
  #1  
Old October 17th, 2020, 04:18 AM
NYKrumrie NYKrumrie is offline
Senior Member
 
Join Date: Sep 2007
O/S: Windows 10 Home
Posts: 124
Why is Firefox saying "web page slowing down browser"?

Hi,

This problem just started about a week or 2 ago. If I open a webpage using the latest Firefox browser its seems eventually no matter what site I go to I get a yellow banner at the top of the browser page that says "A web page is slowing down your browser. What would you like to do"? Then on the far right, there are 2 buttons: Stop It & Wait. No matter what option I pick I get the same yellow warning again. When the warning comes on I notice the pictures, links & other options on the page being shown are frozen. For instance, if I'm on ESPN & get the warning & can not click on anything to go to a new page. after a minute or 2, it allows you to click & move on. I'm generally on the same pages every day. ESPN, Realclaerpolitics, ESPN fantasy football. I'm not steaming anything & not on youtube. I have noticed that when I'm on Chrome & watching a video but not directly from youtube the video will play but I get a notice saying something is wrong with the page. If you hit any button on the video player the video crashes. I did a quick search for an answer. I was told to clear all my browser data, cookies, temp files history etc. I did that twice but it didn't help. So I'm wondering if this has something to do with new Win 10 updates I've been asked to do recently? Any ideas wuld be greatly appreciated.

Thanks!
Reply With Quote


  #2  
Old October 21st, 2020, 05:07 AM
NYKrumrie NYKrumrie is offline
Senior Member
 
Join Date: Sep 2007
O/S: Windows 10 Home
Posts: 124
Found a FIX!

I think I found a fix!

I wanted to give an update. I did some digging & found a solution...so far. I did the steps below & my FF seems to be running smoother & the annoying warning has not come up in days. In short, it seems to be a settings issue. I was advised to go into settings.

-Go to the 3 bars on the top right corner of the browser.

-Go to "Options".

-Go to "Privacy & Security". You might be on the "Standard" options as the default.

-Select "Strict" as your new option.


I closed FF & reopened it & the problem seems to be gone. I hope this works for anyone else out there needing help.

Thanks!
Reply With Quote
Reply

Bookmarks

Topic Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT +1. The time now is 06:59 PM.