Go Back   Cyber Tech Help Support Forums > Operating Systems > Windows 7

Notices

Reply
 
Topic Tools
  #31  
Old February 5th, 2015, 06:24 PM
Murf's Avatar
Murf Murf is offline
Moderator
 
Join Date: Oct 2001
O/S: Windows 10 Home
Location: Newport News VA
Age: 75
Posts: 17,236
In your Bios SETUP under Integrated Peripherals

You will see On-Chip SATA Mode

Set to ENHANCED

Save and Exit

However, if you have any IDE drives then try COMBINED
Reply With Quote


  #32  
Old February 6th, 2015, 01:25 PM
lcyber lcyber is offline
CTH Subscriber
 
Join Date: Feb 2003
O/S: Windows 7 64-bit
Location: uk
Posts: 1,451
Yes I have done that and ON-CHIP SATA MODE is shown as enhanced in integrated peripherals but I can,t see any mention in BIOS or CMOS of ACHI,what's my next step.I have disabled the IDE setting in integrated peripherals because I only have ssd connected not IDE
Reply With Quote
  #33  
Old February 7th, 2015, 11:08 AM
lcyber lcyber is offline
CTH Subscriber
 
Join Date: Feb 2003
O/S: Windows 7 64-bit
Location: uk
Posts: 1,451
This silence is killing me
Reply With Quote
  #34  
Old February 7th, 2015, 11:16 AM
lcyber lcyber is offline
CTH Subscriber
 
Join Date: Feb 2003
O/S: Windows 7 64-bit
Location: uk
Posts: 1,451
Murf I found this in the web,are there any flaws in it before I have a go at it,can I come unstuck in anyway:

To answer that question (and I do this safely with all Intel ICHR9/10 chipsets) there is a way to safely enable AHCI mode. Here we go:

1. Startup "Regedit
2. Open HKEY_LOCAL_MACHINE / SYSTEM / CurrentControlset / Services
3. Open msahci
4. In the right field left click on "start" and go to Modify
5. In the value Data field enter "0" and click "ok"
6. exit "Regedit"
7. Reboot Rig and enter BIOS (hold "Delete" key while Booting

In your BIOS select "Integrated Peripherals" and OnChip PATA/SATA Devices. Now change SATA Mode to AHCI from IDE.

You now boot into windows 7, the OS will recognize AHCI and install the devices. Now the system needs one more reboot and voilla .. enjoy the improved SSD performance.

What's your opinion Murf
Reply With Quote
  #35  
Old February 7th, 2015, 10:26 PM
Murf's Avatar
Murf Murf is offline
Moderator
 
Join Date: Oct 2001
O/S: Windows 10 Home
Location: Newport News VA
Age: 75
Posts: 17,236
Your BIOS may not say "ACHI" not all do.

In device manager expand IDE ATA/ATAPI controllers

Do you see a controller labeled AHCI or Advanced?, if you only see Advanced right click on it then to Properties then to Details, under value what do you see?
Reply With Quote
  #36  
Old February 8th, 2015, 01:12 PM
lcyber lcyber is offline
CTH Subscriber
 
Join Date: Feb 2003
O/S: Windows 7 64-bit
Location: uk
Posts: 1,451
All that is shown after expanding IDE/ATAPA Controllers is
ATA Channel 0
ATA Chanell 1
Intel(R)82801GB/GH/(ICH7 famiy) Serial ATA Storage Controler 27C0
Reply With Quote
  #37  
Old February 9th, 2015, 07:04 PM
Murf's Avatar
Murf Murf is offline
Moderator
 
Join Date: Oct 2001
O/S: Windows 10 Home
Location: Newport News VA
Age: 75
Posts: 17,236
Obviously you not running in ACHI mode.

Same as what you found but an additional registry key try the FIX Button;

http://support.microsoft.com/kb/922976?wa=wsignin1.0
Reply With Quote
  #38  
Old February 10th, 2015, 11:50 AM
lcyber lcyber is offline
CTH Subscriber
 
Join Date: Feb 2003
O/S: Windows 7 64-bit
Location: uk
Posts: 1,451
Quote:
Originally Posted by Murf View Post
Obviously you not running in ACHI mode.

Same as what you found but an additional registry key try the FIX Button;

http://support.microsoft.com/kb/922976?wa=wsignin1.0
Just one reservation about this link,if I get a blue screen I've seen mentioned' how do I undo this fix without a screen if I need to?
Reply With Quote
  #39  
Old February 12th, 2015, 04:16 PM
Murf's Avatar
Murf Murf is offline
Moderator
 
Join Date: Oct 2001
O/S: Windows 10 Home
Location: Newport News VA
Age: 75
Posts: 17,236
Back up those registry keys first; In the registry highlight the key then go to FILE>Export put on desktop, it will be a *.reg file (name it what you want).

If for some reason you need to revert, reboot into SAFE MODE, double click the *.reg file and it will import back in. Then reboot.
Reply With Quote
  #40  
Old February 13th, 2015, 08:54 PM
lcyber lcyber is offline
CTH Subscriber
 
Join Date: Feb 2003
O/S: Windows 7 64-bit
Location: uk
Posts: 1,451
Got as far as regedit.exe then was presented with a choice of five keys HKEY_CLASSES_ROOT HKEY _ CURRENT _USER HKEY_LOCAL MACHINE HKEY_USER HKEY_ CURRENT_ CONFIG ,do I take it that the key to highlight is the "current config"
Reply With Quote
  #41  
Old February 13th, 2015, 11:32 PM
Murf's Avatar
Murf Murf is offline
Moderator
 
Join Date: Oct 2001
O/S: Windows 10 Home
Location: Newport News VA
Age: 75
Posts: 17,236
Did you try the automatic fix button? In the link I gave you? If that doesn't work then rather then changing the registry we can try something else. Anyway the keys are:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\Msahci

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\IastorV

You keep expanding by clicking the little arrow until you get to that key.
Reply With Quote
  #42  
Old February 14th, 2015, 12:55 PM
lcyber lcyber is offline
CTH Subscriber
 
Join Date: Feb 2003
O/S: Windows 7 64-bit
Location: uk
Posts: 1,451
I tried the automatic fix button but nothing shows up in IDE Controllers in device manager
Reply With Quote
  #43  
Old February 15th, 2015, 01:37 AM
Murf's Avatar
Murf Murf is offline
Moderator
 
Join Date: Oct 2001
O/S: Windows 10 Home
Location: Newport News VA
Age: 75
Posts: 17,236
After auto did you reboot?

Then reboot again and go back into your BIOS Setup and change the entry from IDE to Sata, save and exit.
Reply With Quote
  #44  
Old February 15th, 2015, 09:20 PM
lcyber lcyber is offline
CTH Subscriber
 
Join Date: Feb 2003
O/S: Windows 7 64-bit
Location: uk
Posts: 1,451
Can,t change IDE to SATA as it is Greened out prefixed with a star

PATA IDE Port Set to Ch0 Master/Slave
SATA Port 0/2 Set to Ch2 Master/Slave
SATA Port 1/3 Set to Ch 3 Master/Slave

All these are Greened out in BOS
Reply With Quote
  #45  
Old February 16th, 2015, 02:07 AM
Murf's Avatar
Murf Murf is offline
Moderator
 
Join Date: Oct 2001
O/S: Windows 10 Home
Location: Newport News VA
Age: 75
Posts: 17,236
Well I have done some research and everything I am reading is pointing to the ICH7 Chipset DOES NOT support AHCI. So unless someone else can verify it does, I would go back into BIOS and change SATA back to the way you had it in the beginning.
Reply With Quote
Reply

Bookmarks

Topic Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT +1. The time now is 07:11 AM.