Go Back   Cyber Tech Help Support Forums > Operating Systems > Windows 7

Notices

Reply
 
Topic Tools
  #1  
Old October 23rd, 2009, 12:50 AM
michael123's Avatar
michael123 michael123 is offline
Senior Member
 
Join Date: Feb 2007
O/S: Windows XP Pro
Location: UK
Posts: 303
Exclamation Windows Experience Index Not Working

Hi, I've got a problem with my new Windows 7 installation where I get the following error message when I try to run the Windows Experience Index:

Quote:
The windows experience index for your system could not be computed. The assessment or other operation did not complete successfully. This is due to an error being reported from the operating system, driver or other component.
I've tried running chkdsk and deleting the DataStore folder in Windows\Performance\WinSat and neither of these things has had any effect. I've also tried updating my graphics drivers, to no avail. As a result of not having an experience index, I get very sporadic Aero support.

The log file for the attempt is here, if someone could just point out the hardware/software that is causing that problem that would be really helpful:

Quote:
462886 (2436) - winsat\logging.cpp:0815: --- START 2009\10\23 00:36:23 ---
462886 (2436) - winsat\main.cpp:4301: Command Line = "C:\Windows\system32\winsat.exe" formal -cancelevent 5e9db792-5a3a-4833-a7eb-3143d0b6d13f
462886 (2436) - winsat\processwinsaterror.cpp:0095: ERROR: tried to read resource strings, unknown exception occured
462886 (2436) - winsat\main.cpp:4474: > IsFormal=TRUE IsMoobe=FALSE.
462917 (2436) - winsat\main.cpp:4585: Watch dog system enabled
462917 (2436) - winsat\main.cpp:4600: Main watch dog timer set to 600.0 seconds
462917 (2436) - winsat\main.cpp:3115: A failure occured while trying to read partial assessments from the datastore. Running full assessment
462917 (2436) - winsat\main.cpp:2490: > DWM Running.
463229 (2436) - winsat\main.cpp:2497: > turning off DWM.
463229 (2436) - winsat\main.cpp:2470: > EMD service will be restored on exit.
463369 (2436) - winsat\syspowertools.cpp:0983: > Read the active power scheme as '381b4222-f694-41f0-9685-ff5bb260df2e'
463369 (2436) - winsat\main.cpp:2793: > power policy saved.
463400 (2436) - winsat\syspowertools.cpp:1015: > Set the active power scheme to 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c'
463400 (2436) - winsat\main.cpp:2814: > power policy set to maximum.
464227 (2436) - winsat\logging.cpp:1763: ERROR: pahse enter/leave imballance
464227 (2436) - winsat\main.cpp:0948: > IsOfficial=TRUE IsFormal=TRUE IsMoobe=FALSE RanOverTs=FALSE RanOnbatteries=FALSE
464227 (2436) - winsat\main.cpp:1775: > Run Assessment features
464305 (2436) - winsat\main.cpp:1775: > Run Assessment dwm -aname DWM -time 10 -fbc 10 -disp off -normalw 12 -width 1280 -height 1024 -winwidth C(1144) -winheight C(915) -rendertotex 6 -rtdelta 3 -nolock
476349 (2436) - winsat\processresults.cpp:4018: > Wrote video memory bandwidth to the registry 19081400
476349 (2436) - winsat\main.cpp:2037: > DWM Assessment results processing SUCCESS
476349 (2436) - winsat\main.cpp:1775: > Run Assessment d3d -aname Batch -time 5 -fbc 10 -disp off -animate 10 -width 1280 -height 1024 -totalobj 300 -batchcnt C(10) -objs C(26) -rendertotex 6 -rtdelta 3 -texpobj C(1)
483010 (2436) - winsat\main.cpp:1775: > Run Assessment d3d -aname Alpha -time 5 -fbc 10 -disp off -animate 10 -width 1280 -height 1024 -totalobj 300 -batchcnt C(75) -objs C(26) -rendertotex 6 -rtdelta 3 -texpobj C(1)
490155 (2436) - winsat\main.cpp:1775: > Run Assessment d3d -aname Tex -time 5 -fbc 10 -disp off -animate 10 -width 1280 -height 1024 -totalobj 500 -batchcnt C(125) -objs C(20) -noalpha -texshader -totaltex 10 -texpobj C(4) -rendertotex 6 -rtdelta 3
496722 (2436) - winsat\main.cpp:1775: > Run Assessment d3d -aname ALU -time 5 -fbc 10 -disp off -animate 10 -width 1280 -height 1024 -totalobj 500 -batchcnt C(125) -objs C(20) -noalpha -alushader -totaltex 10 -texpobj C(1) -rendertotex 6 -rtdelta 3
503384 (2436) - winsat\main.cpp:1775: > Run Assessment d3d -dx10 -aname Batch -time 5 -fbc 10 -disp off -animate 10 -width 1280 -height 1024 -totalobj 300 -batchcnt C(10) -objs C(26) -rendertotex 6 -rtdelta 3 -texpobj C(1)
509624 (2436) - winsat\main.cpp:1775: > Run Assessment d3d -dx10 -aname Alpha -time 5 -fbc 10 -disp off -animate 10 -width 1280 -height 1024 -totalobj 300 -batchcnt C(75) -objs C(26) -rendertotex 6 -rtdelta 3 -texpobj C(1)
515879 (2436) - winsat\main.cpp:1775: > Run Assessment d3d -dx10 -aname Tex -time 5 -fbc 10 -disp off -animate 10 -width 1280 -height 1024 -totalobj 500 -batchcnt C(125) -objs C(20) -noalpha -texshader -totaltex 10 -texpobj C(4) -rendertotex 6 -rtdelta 3
522150 (2436) - winsat\main.cpp:1775: > Run Assessment d3d -dx10 -aname ALU -time 5 -fbc 10 -disp off -animate 10 -width 1280 -height 1024 -totalobj 500 -batchcnt C(125) -objs C(20) -noalpha -alushader -totaltex 10 -texpobj C(1) -rendertotex 6 -rtdelta 3
528484 (2436) - winsat\main.cpp:1775: > Run Assessment d3d -dx10 -aname GeomF4 -time 7 -fbc 10 -disp off -animate 10 -width 1280 -height 1024 -totalobj 150;200;241 -batchcnt C(50);C(200);C(300) -objs C(12);C(26);C(45) -noalpha -geomf4shader -texpobj C(0) -rendertotex 6 -rtdelta 3 -tierframes 60 -tiertime 1
537329 (2436) - winsat\main.cpp:1775: > Run Assessment d3d -dx10 -aname GeomV8 -time 7 -fbc 10 -disp off -animate 10 -width 1280 -height 1024 -totalobj 75;100;120 -batchcnt C(25);C(100);C(150) -objs C(8);C(17);C(29) -noalpha -geomv8shader -texpobj C(0) -rendertotex 6 -rtdelta 3 -tierframes 60 -tiertime 1
545629 (2436) - winsat\main.cpp:1775: > Run Assessment d3d -dx10 -aname CBuffer -time 5 -fbc 10 -disp off -animate 10 -width 1280 -height 1024 -totalobj 75 -batchcnt C(25) -objs C(8) -rendertotex 6 -rtdelta 3 -texpobj C(1) -cbuffershader -cbufa 2 -cbuff 5 -cbufp 6
551713 (2436) - winsat\main.cpp:1775: > Run Assessment mfmedia -input C:\Windows\Performance\WinSAT\winsat.wmv -nopmp
553803 (2436) - winsat\main.cpp:1775: > Run Assessment mediaex -input C:\Windows\Performance\WinSAT\Clip_1080_5sec_MPEG2 _HD_15mbps.mpg -dshow -video offscreen -audio mute -width 100%m -height 100%m -constrain -savereg -autoprofname -expfrmmin 270 -expfrmmax 300 -overrideframetype int2fps
560729 (2436) - winsat\main.cpp:1775: > Run Assessment mediaex -input C:\Windows\Performance\WinSAT\Clip_1080_5sec_VC1_1 5mbps.wmv -video offscreen -audio mute -width 100%m -height 100%m -constrain -savereg -autoprofname -expfrmmin 135 -expfrmmax 150 -overrideframetype prog
567718 (2436) - winsat\main.cpp:1775: > Run Assessment mediaex -input C:\Windows\Performance\WinSAT\Clip_480i_5sec_6mbps _new.mpg -dshow -video offscreen -audio mute -width 100%m -height 100%m -constrain -savereg -autoprofname -expfrmmin 270 -expfrmmax 300 -overrideframetype int2fps
574614 (2436) - winsat\main.cpp:1775: > Run Assessment mediaex -input C:\Windows\Performance\WinSAT\Clip_480p_5sec_6mbps _new.mpg -dshow -video offscreen -audio mute -width 100%m -height 100%m -constrain -savereg -autoprofname -expfrmmin 135 -expfrmmax 150 -overrideframetype prog
581556 (2436) - winsat\main.cpp:1775: > Run Assessment mediaex -input C:\Windows\Performance\WinSAT\Clip_1080_5sec_10mbp s_h264.mp4 -video offscreen -audio mute -width 100%m -height 100%m -constrain -savereg -autoprofname -expfrmmin 135 -expfrmmax 150 -overrideframetype prog
588076 (2436) - winsat\main.cpp:1775: > Run Assessment mediaex -input C:\Windows\Performance\WinSAT\Clip_480_5sec_6mbps_ h264.mp4 -video offscreen -audio mute -width 100%m -height 100%m -constrain -savereg -autoprofname -expfrmmin 270 -expfrmmax 300 -overrideframetype int2fps
594519 (2436) - winsat\main.cpp:1775: > Run Assessment media -input C:\Windows\Performance\WinSAT\winsatencode.wmv -encode C:\Windows\Performance\WinSAT\winsat.prx
598139 (2436) - winsat\main.cpp:1775: > Run Assessment moobego
598139 (2436) - winsat\main.cpp:1775: > Run Assessment cpu -encryption -up
601165 (2436) - winsat\main.cpp:1775: > Run Assessment cpu -compression -up
611227 (2436) - winsat\main.cpp:1775: > Run Assessment cpu -encryption2 -up
614300 (2436) - winsat\main.cpp:1775: > Run Assessment cpu -compression2 -up
624425 (2436) - winsat\main.cpp:1775: > Run Assessment cpu -encryption
627638 (2436) - winsat\main.cpp:1775: > Run Assessment cpu -compression
637794 (2436) - winsat\main.cpp:1775: > Run Assessment cpu -encryption2
640930 (2436) - winsat\main.cpp:1775: > Run Assessment cpu -compression2
651210 (2436) - winsat\main.cpp:1775: > Run Assessment mem
656545 (2436) - winsat\main.cpp:1775: > Run Assessment disk -seq -read -n 1
667341 (2436) - winsat\main.cpp:1775: > Run Assessment disk -ran -read -n 1
681505 (2436) - winsat\main.cpp:1775: > Run Assessment disk -scen 2009 -drive C:
750630 (2436) - winsat\processresults.cpp:4018: > Wrote video memory bandwidth to the registry 19081400
750630 (2436) - winsat\processresults.cpp:0962: > Wrote cpu expression compression score to the registry 151
750630 (2436) - winsat\processresults.cpp:1004: Total physical mem available to the OS : 1.99 GB (2,142,756,864 bytes)
750630 (2436) - winsat\processresults.cpp:1086: Physical memory available to the OS is less than 3.0GB-64MB : limit mem score to 5.5
750630 (2436) - winsat\processresults.cpp:1253: Skipping StdDefPlayback limit check.
750630 (2436) - winsat\processresults.cpp:1265: Skipping StdDefPlayback limit check.
750630 (2436) - winsat\processresults.cpp:1480: > Wrote disk score to the registry 590
750630 (2436) - winsat\processresults.cpp:1498: > Wrote random read disk score to the registry 1423
750661 (2436) - winsat\main.cpp:0948: > IsOfficial=TRUE IsFormal=TRUE IsMoobe=FALSE RanOverTs=FALSE RanOnbatteries=FALSE
750661 (2436) - winsat\main.cpp:4736: ERROR: Unable to save validated results.
750692 (2436) - winsat\syspowertools.cpp:1015: > Set the active power scheme to 381b4222-f694-41f0-9685-ff5bb260df2e'
750692 (2436) - winsat\main.cpp:2855: > Power state restored.
750692 (2436) - winsat\main.cpp:2870: > Successfully reenabled EMD.
750692 (2436) - winsat\main.cpp:2896: > Composition restarted
750692 (2436) - winsat\watchdog.cpp:0311: Watch dog system shutdown
750708 (2436) - winsat\main.cpp:4909: > exit value = 1.
Thanks a lot.

Last edited by michael123; October 23rd, 2009 at 12:55 AM.
Reply With Quote


  #2  
Old October 23rd, 2009, 02:01 AM
AnnMarie's Avatar
AnnMarie AnnMarie is offline
CTH Subscriber
 
Join Date: Oct 2001
O/S: Windows Vista 32-bit
Location: New Zealand
Posts: 59,812
Hi Micheal, I see that you have a Gigabyte P55M-UD2 Motherboard. This issue may be caused by an driver. See here for an interesting discussion.
Reply With Quote
  #3  
Old October 23rd, 2009, 01:27 PM
michael123's Avatar
michael123 michael123 is offline
Senior Member
 
Join Date: Feb 2007
O/S: Windows XP Pro
Location: UK
Posts: 303
Hmmm that's annoying, I guess I'll have to wait for Gigabyte/MS to fix the issue. Thanks for your help and speedy response.
Reply With Quote
  #4  
Old October 23rd, 2009, 10:21 PM
AnnMarie's Avatar
AnnMarie AnnMarie is offline
CTH Subscriber
 
Join Date: Oct 2001
O/S: Windows Vista 32-bit
Location: New Zealand
Posts: 59,812
You are welcome.
Reply With Quote
  #5  
Old October 24th, 2009, 11:47 AM
home4tea's Avatar
home4tea home4tea is offline
Member
 
Join Date: Oct 2009
O/S: Windows 7 64-bit
Location: UK
Posts: 96
Another possible answer...

I notice your log showed the line "750661 (2436) - winsat\main.cpp:4736: ERROR: Unable to save validated results." I too had a similar issue but with an ASUS P5N-E SLI mobo. The Windows Experience Index *was* working and after installing a few applications it stopped working and the WEI log showed "Unable to save".

In my case it appears to have been Kaspersky Internet Security 2010 which was blocking WEI from saving the results. The complete WEI test ran OK and even flashed-up the 'completed' message but this was then immediately replaced with the "assessment could not be completed" message ... because it could not *save* the results.

Can I suggest you try another AV package? If you disconnect the network cable you could safely uninstall your existing AV package and see if WEI works again. If that resolves it, perhaps you need a different AV package from now on.

Personally, I found that Microsoft Security Essentials appears to not have this issue and I can now get my rating again. But I may try some other (try before you buy) packages to see what's best.

Worth a try?

Keith.
Reply With Quote
  #6  
Old October 24th, 2009, 01:05 PM
BM2KTom BM2KTom is offline
New Member
 
Join Date: Oct 2009
Posts: 1
I joined just to say thank you to home4tea, I looked everywhere for a solution to this problem and removing kaspersky was the answer. I tried just disabling the protection but I would still get the cannot save error, I had to use the kaspersky removal tool to completely get rid of it before the windows experience index would complete, thanks again.
Reply With Quote
  #7  
Old October 24th, 2009, 02:00 PM
home4tea's Avatar
home4tea home4tea is offline
Member
 
Join Date: Oct 2009
O/S: Windows 7 64-bit
Location: UK
Posts: 96
Excellent News

That's great news. I joined simply because I had solved this problem for myself and had noticed that others were also getting the same sort of problem.
Perhaps I'll hang around a bit... TTFN.
Reply With Quote
  #8  
Old October 24th, 2009, 09:30 PM
AnnMarie's Avatar
AnnMarie AnnMarie is offline
CTH Subscriber
 
Join Date: Oct 2001
O/S: Windows Vista 32-bit
Location: New Zealand
Posts: 59,812
Thanks for the help home4tea.
Reply With Quote
  #9  
Old October 26th, 2009, 05:43 PM
home4tea's Avatar
home4tea home4tea is offline
Member
 
Join Date: Oct 2009
O/S: Windows 7 64-bit
Location: UK
Posts: 96
Ooh, that was nice. Everyone likes to be appreciated, I am sure.
It was my pleasure. I am just glad I could help.
Reply With Quote
  #10  
Old October 27th, 2009, 08:14 PM
home4tea's Avatar
home4tea home4tea is offline
Member
 
Join Date: Oct 2009
O/S: Windows 7 64-bit
Location: UK
Posts: 96
Just wanted to declare that I have identified this issue to Kaspersky support. They have suggested a workaround but it didn't work for me. I am waiting for more on this.
Reply With Quote
  #11  
Old October 28th, 2009, 12:15 AM
michael123's Avatar
michael123 michael123 is offline
Senior Member
 
Join Date: Feb 2007
O/S: Windows XP Pro
Location: UK
Posts: 303
home4tea, thank-you for your input, sorry I didn't respond, I haven't been checking this thread recently. I don't have Kapersky, but I'll take what you said into account and have a go at disabling my AV and other running programs.
Reply With Quote
  #12  
Old October 28th, 2009, 02:03 AM
michael123's Avatar
michael123 michael123 is offline
Senior Member
 
Join Date: Feb 2007
O/S: Windows XP Pro
Location: UK
Posts: 303
Finally got it working, it was my own fault really. I hadn't upgraded to the very latest (beta) BIOS from Gigabyte, which wasn't installed automatically by the bundled BIOS updater program. I had to go on the website and manually install it, whereupon it worked fine. Thanks all.
Reply With Quote
  #13  
Old October 28th, 2009, 03:19 AM
AnnMarie's Avatar
AnnMarie AnnMarie is offline
CTH Subscriber
 
Join Date: Oct 2001
O/S: Windows Vista 32-bit
Location: New Zealand
Posts: 59,812
That's good news Michael and thanks for the update.
Reply With Quote
  #14  
Old November 20th, 2009, 10:58 PM
home4tea's Avatar
home4tea home4tea is offline
Member
 
Join Date: Oct 2009
O/S: Windows 7 64-bit
Location: UK
Posts: 96
For the sake of completeness and to give Kaspersky the credit they are due, they have recently (18th November) released "kis9.0.0.736" which includes the fix for the problem with the Windows Experience Index failing to calculate under Windows 7.

Personally, I had to uninstall the old version and install the new version as a fresh install (but keeping the original license installed) to get it working properly. It was continually claiming that the database was out of date until I did that.

Hopefully anyone else looking for this fix will find this information useful.
Reply With Quote
  #15  
Old November 21st, 2009, 04:26 AM
AnnMarie's Avatar
AnnMarie AnnMarie is offline
CTH Subscriber
 
Join Date: Oct 2001
O/S: Windows Vista 32-bit
Location: New Zealand
Posts: 59,812
Thanks for the update Keith.
Reply With Quote
Reply

Bookmarks

Topic Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT +1. The time now is 10:31 AM.