Go Back   Cyber Tech Help Support Forums > Operating Systems > Windows 7

Notices

Reply
 
Topic Tools
  #1  
Old February 6th, 2012, 12:54 AM
Smokey Smokey is offline
Senior Member
 
Join Date: Jan 2002
Location: UK
Posts: 174
Not really thick but I feel like it........

Hi

This is not a phone thread, so please read on. I'm running Windows 7 Home Premium and trying to free up memory on my Android HTC Desire and came upon an article that looked promising (see below). I successfully completed items 1 through 3, but I cannot for the life of me navigate to the Android-SDK/tools folder, saved in C: Program files (x86) via the command prompt. Every time I type in the path I get an error mesage saying 'Program is not recognized as an internal or external command, operable program or batch file.....'

I have no doubt I'm doing something wrong, but can't figure out what it might be. Is the folder in an inaccessible directory? If so, where do I have to move it to get into it..

Thanks in advance for any assistance you can provide




You might think this is impossible. But, it seems nothing impossible when it comes to the Android‘s innovation. You can install as many as applications you want to your SD card on Android Froyo powered phones. It might be rare to see on the other phones with different platforms.

Here is the instruction you should do.

1. Enable USB debugging on your device by clicking on Setting > Applications > Development > USB debugging.

2. Download and install the Android SDK. If you have no idea where to visit, you should go to http://developer.android.com/sdk/

3. Connect your phone to computer.

4. Run a command prompt and navigate to the Android-SDK\tools folder.

5. In the folder you can type adb devices and get the serial number starting with “H” in return.

6. Enter adb shell pm setInstallLocation 2.

7. Enter adb shell pm setInstallLocation 0 if you need to switch back to storing software o[/B][/B]n your internal memory.
Reply With Quote


  #2  
Old February 6th, 2012, 03:14 AM
AnnMarie's Avatar
AnnMarie AnnMarie is offline
CTH Subscriber
 
Join Date: Oct 2001
O/S: Windows Vista 32-bit
Location: New Zealand
Posts: 59,812
Did you enclose the filepath in quotes, i.e. "C:\Program Files (x86)\<foldername>" ? It has spaces so you must use them.
Reply With Quote
  #3  
Old February 6th, 2012, 07:48 AM
Smokey Smokey is offline
Senior Member
 
Join Date: Jan 2002
Location: UK
Posts: 174
Thanks, Anne-Marie. I tried to do that. Extracted the file to desktop to simplify, but the CMD prompt defaults to C:\ without the quotation marks, so I ended up with C:\"users\Steve\desktop\android-skd" and got the same message. Would this work if I could enclose the entire path in quotation marks and if so, how do I get them in front of the C:\???

Thick, thick, thick!!
Reply With Quote
  #4  
Old February 6th, 2012, 07:53 AM
Smokey Smokey is offline
Senior Member
 
Join Date: Jan 2002
Location: UK
Posts: 174
Just looked again, Anne Marie. Actually the prompt defaults to C:/>

Does that make any difference?
Reply With Quote
  #5  
Old February 6th, 2012, 08:25 AM
AnnMarie's Avatar
AnnMarie AnnMarie is offline
CTH Subscriber
 
Join Date: Oct 2001
O/S: Windows Vista 32-bit
Location: New Zealand
Posts: 59,812
No. Just type "C:\users\Steve\desktop\android-skd" after the prompt and hit Enter. There are no spaces in that filepath so the quotes aren't necessary this time.

See below.

Reply With Quote
  #6  
Old February 6th, 2012, 08:50 PM
Smokey Smokey is offline
Senior Member
 
Join Date: Jan 2002
Location: UK
Posts: 174
I did exactly what you suggested Ann Marie and got exactly the same message. Unfortunately, I'm not allowed to post the screen shot as an attachment.

Any ideas??

Thanks
Reply With Quote
  #7  
Old February 6th, 2012, 09:35 PM
AnnMarie's Avatar
AnnMarie AnnMarie is offline
CTH Subscriber
 
Join Date: Oct 2001
O/S: Windows Vista 32-bit
Location: New Zealand
Posts: 59,812
Sorry, I wasnt really paying attention to what you wanted to achieve. You want to change directory right? In that case, type:

cd users\Steve\desktop\android-skd

after the prompt and hit Enter.
Reply With Quote
  #8  
Old February 6th, 2012, 11:16 PM
Smokey Smokey is offline
Senior Member
 
Join Date: Jan 2002
Location: UK
Posts: 174
AnnMarie

That didn't work either, I'm afraid. When I typed in cd users\Steve\desktop\android-sdk\tools I just got the same string as a directory.
Here's another article that illustrates what I'm trying to accomplish. I've emboldened the section I'm stuck on and what should follow if I get it right (finally). Hopefully this will give you a better picture of the desired outcome and if I'm lucky, you'll know how to get me there. Thanks again

To install an app to the SD card on Android Froyo, the application itself needs to support it. In my experience though, most current apps can be moved to the external storage. However, the Froyo system installs all new applications on your device’s internal memory by default, except for those that explicitly request external installation. Luckily, it’s possible to make your Android 2.2 phone put apps on the SD card by default instead. Here’s how:

First you have to enable USB debugging on your Android device from Settings > Applications > Development > USB debugging.
Now you need to download and install the Android SDK on your computer from http://developer.android.com/sdk/. Once you’ve downloaded and extracted the package to the folder of your choice, run SDK Setup.exe and click on Available Packages to the left. If you get an error message at this point, enable “Force https://…” in the Settings. From the list of available packages, select “Usb Driver package”, click on the Install Selected button in the bottom right corner and follow the prompts.
Connect your phone to your computer with a USB-cable. Your OS will prompt you to install new drivers. Choose to install them from the android-sdk/usb_driver folder. Do not mount your device; you only need to plug-in the cable.
Next, run a command prompt and navigate to the Android-SDK\tools folder. In Windows, this is done by selecting Run from the Start Menu (or by pressing Win+R) and typing cmd. You change drives in the command prompt by entering the drive letter followed by a colon (, and change folders with the CD command. For example, to enter the Android-SDK folder, simply type cd android-sdk.
In the Android-SDK\tools folder, type in adb devices and you should get a serial number starting with “H” in return. All you have to do next is entering adb shell pm setInstallLocation 2. Voilà, you’re done! Android will now install apps to the SD card by default.

To switch back to storing software on the internal memory, enter adb shell pm setInstallLocation 0.
Reply With Quote
  #9  
Old February 6th, 2012, 11:28 PM
AnnMarie's Avatar
AnnMarie AnnMarie is offline
CTH Subscriber
 
Join Date: Oct 2001
O/S: Windows Vista 32-bit
Location: New Zealand
Posts: 59,812
In the command prompt, do you see:

C:\users\Steve\desktop\android-sdk\tools> with a blinking cursor after the >? If so, you are in that directory. If the commands (adb devices etc) dont produce the desired result, you are going to have to contact whoever wrote the article or support for your phone. That's not something we can help with here.
Reply With Quote
  #10  
Old February 7th, 2012, 01:29 AM
Smokey Smokey is offline
Senior Member
 
Join Date: Jan 2002
Location: UK
Posts: 174
ok, thanks for trying
Reply With Quote
  #11  
Old February 7th, 2012, 02:06 AM
AnnMarie's Avatar
AnnMarie AnnMarie is offline
CTH Subscriber
 
Join Date: Oct 2001
O/S: Windows Vista 32-bit
Location: New Zealand
Posts: 59,812
No problem. The adb command is Android specific so it's not a Windows command Smokey See if this link helps you http://www.addictivetips.com/mobile/...ll-it-android/
Reply With Quote
Reply

Bookmarks

Topic Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT +1. The time now is 06:48 PM.