Go Back   Cyber Tech Help Support Forums > Operating Systems > Linux

Notices

Reply
 
Topic Tools
  #1  
Old April 8th, 2015, 01:02 AM
sladden sladden is offline
Senior Member
 
Join Date: Feb 2009
O/S: Linux
Location: Tabourie NSW Australia
Age: 81
Posts: 1,288
win8.1 - Mint 17.1

G'day Folks.

I have a Toshiba Kira notebook with win8.1.
If I burn it out. Turn off the microsoft/apple secure boot. Then install a purchased win8.1. Toshiba seems to hate my independence declaration by making it difficult to obtain all the drivers that I need.
So I surrendered. Reset to factory release and dual booted Mint 17.1 xfce by accessing the usb boot from inside win8.1.
It all seemed to work fine until I tried to open the ntfs formatted partitions from inside Mint.

Error mounting /dev/sda5 at /media/dave/New103gb FILES Volume: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dm ask=0077,fmask=0177" "/dev/sda5" "/media/dave/New103gb FILES Volume"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda5': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

If I delete a partion using gparted (from inside Mint) then recreate it. It mounts and works fine.
Until I close Mint then open win8 then close win8 and re-open Mint.
Then the partitions won't mount again.

Does anybody know why this happens please?
Reply With Quote


  #2  
Old April 8th, 2015, 01:23 AM
smurfy's Avatar
smurfy smurfy is offline
Cyber Tech Help Moderator
 
Join Date: Sep 2000
O/S: Linux
Location: Christchurch New Zealand
Posts: 9,535
The key part of the message is
Quote:
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.
When Win 8 "shuts down", it doesn't un-mount the partitions, so you are trying to access a partition that Windows still has its dirty mitts on.
Some info.
Reply With Quote
  #3  
Old April 8th, 2015, 01:23 AM
sladden sladden is offline
Senior Member
 
Join Date: Feb 2009
O/S: Linux
Location: Tabourie NSW Australia
Age: 81
Posts: 1,288
I think I found the reason.
I went back into win8 and it held me up while it went through it's finish updating procedure. Then it went through the flash-stick repair sequence (I had dared to open it in Mint).
After it finished I shut down win8 and re-opened Mint.
Wonder of wonders everything mounted.
Somehow windows mucks up other folders for Linux Mint even if Linux Gparted created the partition.

****Crazy**** but 'Sort-of' solved.
Reply With Quote
  #4  
Old April 8th, 2015, 01:25 AM
smurfy's Avatar
smurfy smurfy is offline
Cyber Tech Help Moderator
 
Join Date: Sep 2000
O/S: Linux
Location: Christchurch New Zealand
Posts: 9,535
A better explanation
Quote:
How to Perform a Full Shutdown

If you want to shut down the computer without using the Hybrid Shutdown behavior, you can use Shutdown.exe to shut down the computer. Full shutdown is the default
when you use Shutdown.exe.

Shutdown /s /t 0

The Shutdown.exe command also includes an optional /hybrid parameter that can be used if you want to use the new method.

What About Restart?

When you restart the computer, that typically means that you want a completely new Windows state, either because you have
installed a driver or replaced Windows elements that cannot be replaced without a full restart.

As a result, the restart process in Windows 8 continues to perform a full boot cycle, without the Hibernation performance improvement mentioned above.
Reply With Quote
  #5  
Old April 8th, 2015, 01:57 AM
sladden sladden is offline
Senior Member
 
Join Date: Feb 2009
O/S: Linux
Location: Tabourie NSW Australia
Age: 81
Posts: 1,288
Thanks Smurfy.
About 'Full Shutdown'.
Currently on this Toshiba dual-boot I have noticed a strange (to me) thing.
If I use win8 then 'Shut Down'. It shuts down. When I open the lid I must press the 'Start' button to open the computer.

If I use Mint 17.1.
When I go through 'G' and 'Shut Down' then close the lid and leave the note-book for a while.
Next time I lift the lid the screen lights up and goes into offering me a boot choice,without me pressing the start button.

To shut down from Mint 17.1 I must press and hold the On/Off button until it turns off.
Reply With Quote
  #6  
Old April 16th, 2015, 01:54 PM
reeclarck reeclarck is offline
New Member
 
Join Date: Apr 2015
Posts: 2
When Win 8 "shuts down", it doesn't un-mount the partitions, so you are trying to access a partition that Windows still has its dirty mitts on.? solved
Reply With Quote
  #7  
Old April 16th, 2015, 01:55 PM
reeclarck reeclarck is offline
New Member
 
Join Date: Apr 2015
Posts: 2
Thanks for sharing............
Reply With Quote
Reply

Bookmarks

Topic Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT +1. The time now is 03:36 AM.