View Single Post
  #1  
Old November 5th, 2015, 06:21 AM
Torm1 Torm1 is offline
New Member
 
Join Date: Apr 2006
Posts: 27
Crashing After 10 Minutes on Any Game

Hello All,

My Windows 7 PC runs fine when doing anything other than games. Using an internet browser, watching YouTube, copying and burning disks all present no issue. Play a game, however, and I'll be able to play for perhaps 5 minutes before either a black screen and PC lockup, a BSOD, or sometimes luckily it will only be a CTD.

The latest example of this is with Civilisation V, but this also occurs with Crysis 2 and even Minecraft. In Civilisation V, I will get in four or so turns before a CTD when using DX10-11 and when using DX9 I'll get a BSOD at about the same time. With Crysis 2 and most other games, it's normally a frozen PC with perhaps a BSOD or two in there.

I have tried updating my drivers on graphics cards and any other hardware that seemed relevant. I've tried dumbing down graphics settings to as low as they would go. That did not work with Crysis2, Civ V, or any other game, but it did seem to work for Minecraft for a little while. I've also tried reinstalls of all three of these games.

Other games where the same 10 minute failure occurs include: Empire, Napoleon, and Shogun of Total War as well as Tropico 4.

Perhaps I'd better post my specs:

Operating System
MS Windows 7 Home Premium 64-bit SP1
CPU
Intel Core 2 Quad Q9550 @ 2.83GHz 48 C
Yorkfield 45nm Technology
RAM
12.0 GB Dual-Channel DDR3 @ 666MHz (9-9-9-24)
Motherboard
Gigabyte Technology Co., Ltd. EP45T-UD3P (Socket 775) 44 C
Graphics
BenQ G2400W (1920x1200@59Hz)
1279MB GeForce GTX 570 (EVGA) 45 C
Hard Drives
138GB Volume0 (SATA)
1863GB Seagate ST2000DM001-1ER164 (SATA) 47 C
279GB Western Digital WDC WD3000HLFS-01G6U0 (SATA) 55 C
233GB Seagate ST3250823AS (SATA) 53 C
Optical Drives
PIONEER DVD-RW DVR-111D SCSI CdRom Device
PIONEER BD-RW BDR-203
Audio
Realtek High Definition Audio

This problem has been in existence for at least a year. Somehow, I got Minecraft working for a little while and resorted to a console for games and just ignored the problem. In desperation, I must turn to you. This may well be a hardware or OS problem. If that is the case, please let me know and I'll post elsewhere.

If you can offer any help or suggestions as to what to try, please feel free. It would be most appreciated!

With thanks,

Torm1

PS. I have bought all of my games (including the physical cases). The version of Civ V has both Gods and Kings and Brave New World. The rest were all updated to their latest patches. As far as I can tell, my system specs are more than sufficient for these games.
Reply With Quote