Cyber Tech Help Support Forums

Cyber Tech Help Support Forums (
-   Windows Vista (
-   -   Open File Location doesn't work (

telanor September 25th, 2010 06:10 AM

Open File Location doesn't work
For some reason the "Open File Location" command on shortcuts has stopped working for me. When I click it, nothing happens. No window opens, no error shows up, nothing. I tried running sfc /scannow but that didn't help. How can I fix this? I'm running windows vista business x64 sp2.

Mosaic1 September 25th, 2010 02:43 PM

First let's have a look to see if that shell menu handler is registered properly.

Copy the contents of the code box to notepad.
Nane the file link.bat
Save as Type: All files

echo Querying  HKCR\CLSID\{37ea3a21-7493-4208-a011-7f9ea79ce9f5} >results.txt

reg query HKCR\CLSID\{37ea3a21-7493-4208-a011-7f9ea79ce9f5} /s >>results.txt 2>&1
echo Querying HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandlers\OpenContainingFolderMenu >>results.txt
reg query HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandlers\OpenContainingFolderMenu /s >>results.txt 2>&1

Start results.txt

Double click on link.bat to run it.

When finished, a file named results.txt will open. Post the contents of results.txt into your next reply here,please.

We'll take it from there.

telanor September 25th, 2010 07:19 PM

Here are the contents of results.txt:

Querying HKCR\CLSID\{37ea3a21-7493-4208-a011-7f9ea79ce9f5}

(Default) REG_SZ Open Containing Folder Menu

(Default) REG_EXPAND_SZ %SystemRoot%\system32\shell32.dll
ThreadingModel REG_SZ Apartment

Querying HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandl ers\OpenContainingFolderMenu

HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandl ers\OpenContainingFolderMenu
(Default) REG_SZ {37ea3a21-7493-4208-a011-7f9ea79ce9f5}

Mosaic1 September 25th, 2010 10:06 PM

Those entries are correct. Let's have a look at one more place:
Copy the contents of the code box to notepad.
Name the file WOWlink.bat
Save as Type: All files


reg query  HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{37ea3a21-7493-4208-a011-7f9ea79ce9f5 /s} >WOWresults.txt 2>&1
Start WOWresults.txt

Double click on WOWlink.bat to run it.

When finished, a file named WOWresults.txt will open. Post the contents of WOWresults.txt into your next reply here,please.

telanor September 25th, 2010 10:08 PM

I assume you meant to put the /s after the }, since it gave me an error otherwise. Heres the output

(Default) REG_SZ Open Containing Folder Menu

(Default) REG_EXPAND_SZ %SystemRoot%\system32\shell32.dll
ThreadingModel REG_SZ Apartment

Mosaic1 September 25th, 2010 10:23 PM

Does this happen only on desktop shortcuts?

telanor September 25th, 2010 10:26 PM

It happens to anything that is a shortcut, regardless of where it is. Basically anything that has "Open File Location" doesn't work.

Mosaic1 September 26th, 2010 04:25 AM

Thanks for catching the typo. Yes. You fixed it correctly. I have Windows7 64 bit. I tried to reproduce your situation here and couldn't. You have another option. There is a way to add a menu option to do the same thing as the Shell Extenson which isn't working. Or I can continue to try tacking down the problem.

Here's a link to a page with the instructions if you want to use this alternative. I used to use it myself when I ran XP and it worked. The only issue might be if you had a security program which used script blocking , or had the file assocation changed so that scripts would open in Notepad.

Mosaic1 September 26th, 2010 04:31 AM

I just ran across a post where the person had exactly the same problem as yours. He had installed Internet Explorer Beta. Uninstalling that fixed the problem.

telanor September 26th, 2010 05:00 AM

Interesting. I just installed IE9 beta. I'll go uninstall it and see if this helps.

Mosaic1 September 26th, 2010 05:24 AM

Thanks. I will be very interested to hear how that goes. We'll be getting a lot of posts about this issue once more people install it.

telanor September 26th, 2010 05:25 AM

Uninstalled and its working again. I would never have thought IE9 was the cause. Thanks for finding that out.

Mosaic1 September 26th, 2010 06:15 AM

You're welcome. Everything else is running ok? I'm nolt sure ,but you may now need to visit Windows Update,check your history and reinstall any Internet Explorer Security Updates.

telanor September 26th, 2010 06:36 AM

That's alright, I don't use IE anyway, I only installed the beta to check it out.

Mosaic1 September 26th, 2010 06:39 AM

Even so, important system files and settings are often changed by these IE security patches.

Aarontica June 30th, 2011 05:11 PM

I'm having this same problem, but I went and unistalled IE9 and it didn't help. I went and did the two notepad tests that were posted and they came out just like the results posted.

brieniuluff September 7th, 2017 08:17 PM

Open File Location doesnt work
I love zombie threads....

All times are GMT +1. The time now is 09:22 PM.

Copyright © Cyber Tech Help. All rights reserved. All other trademarks are the property of their respective owners.